summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-07 17:57:27 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-07 17:57:27 (GMT)
commit25df1908bc0430994cecc9f1415838f42fe0c816 (patch)
treebce2777e087cc7d547e7b644f908eff72282bb53 /fortran/src/Makefile.am
parent630b2901c53c66c837e39babe9da0c20020e5d4d (diff)
downloadhdf5-25df1908bc0430994cecc9f1415838f42fe0c816.zip
hdf5-25df1908bc0430994cecc9f1415838f42fe0c816.tar.gz
hdf5-25df1908bc0430994cecc9f1415838f42fe0c816.tar.bz2
[svn-r10158] Purpose:
Automake version upgrade Description: Upgraded automake version from 1.6.2 to 1.9.5. Changed bin/reconfigure script to use automake 1.9.5. Changed configure.in and Makefiles to use new FCFLAGS and FC variables instead of FFLAGS and F9X. Automake and configure should now do the lion's share of the work supporting Fortran 9X; macros in acsite.m4 are now mostly unused (will be cleaned later). Altered how configure handles pmake; now root-level Makefile.in is processed by bin/reconfigure to have a .MAKEFLAGS target, since automake no longer allows us to define unused variables. Configure now always checks for C++ compiler even if it is not used, since automake thinks this is the Right Thing To Do and will break otherwise. Platforms tested: Sol, copper, heping, mir, sleipnir, eirene, pommier, kelgia, modi4.
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 351ecbd..d6a56f8 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -22,7 +22,7 @@ include $(top_srcdir)/config/commence.am
# Include src directory in both Fortran and C flags (C compiler is used
# for linking)
INCLUDES = -I$(top_srcdir)/src
-AM_FFLAGS=-I$(top_srcdir)/src
+AM_FCFLAGS=-I$(top_srcdir)/src
# Fortran libraries are linked statically to solve a build problem.
AM_LDFLAGS=-static