summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorVailin Choi <vchoi@hdfgroup.org>2013-10-21 16:12:33 (GMT)
committerVailin Choi <vchoi@hdfgroup.org>2013-10-21 16:12:33 (GMT)
commit2b18e934c6812fd1b487ebfebf9240b009c3e4ae (patch)
tree4c5f328cf76071650907986d781191af05a3374a /fortran/src/Makefile.am
parent0a9249a4016f327a3382a103d1b3d10cc6451a5a (diff)
downloadhdf5-2b18e934c6812fd1b487ebfebf9240b009c3e4ae.zip
hdf5-2b18e934c6812fd1b487ebfebf9240b009c3e4ae.tar.gz
hdf5-2b18e934c6812fd1b487ebfebf9240b009c3e4ae.tar.bz2
[svn-r24336] Bring revisions #24118 - #24200 from trunk.
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 12c38e2..2d597c6 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -79,8 +79,11 @@ libhdf5_fortran_la_SOURCES=H5f90global.f90 \
H5Aff$(F_STATUS).f90 H5Dff$(F_STATUS).f90 H5Eff$(F_STATUS).f90 H5Fff$(F_STATUS).f90 H5Lff$(F_STATUS).f90 \
H5Off$(F_STATUS).f90 H5Pff$(F_STATUS).f90 H5Rff$(F_STATUS).f90 H5Tff$(F_STATUS).f90 $(PARALLEL_COND_SRC)
-# HDF5 Fortran library depends on HDF5 Library.
+# HDF5 Fortran library depends on HDF5 Library. However, only add the dependency
+# if --enable-sharedlib-rpath is yes.
+if LT_ADD_LIBHDF5_DEPENDENCY
libhdf5_fortran_la_LIBADD=$(LIBHDF5)
+endif
# h5fc is generated during configure.
# Remove it only when distclean.