summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-06-30 23:35:32 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-06-30 23:35:32 (GMT)
commit43f091f462202a84a863f000582e75fd6c04e6f4 (patch)
tree00bd95eeb9f866516324e4481a78174e6628d651 /fortran/src/Makefile.am
parentafcd1ddb398e04006da8b11a95a60cec61da7349 (diff)
downloadhdf5-43f091f462202a84a863f000582e75fd6c04e6f4.zip
hdf5-43f091f462202a84a863f000582e75fd6c04e6f4.tar.gz
hdf5-43f091f462202a84a863f000582e75fd6c04e6f4.tar.bz2
[svn-r11008] Purpose:
Feature: tests now use parallel make and only run once Description: When make is invoked in parallel (using the -j option), several tests will now be run simultaneously. This should speed up testing on a number of systems. When a test passes, it creates a foo.chkexe or foo.chksh file, which prevents the test from running again unless the test or library changes. Solution: Most of the changes live in config/conclude.am. Added *.chkexe and *.chksh files to the list of files to be cleaned at "make mostlyclean" time. Parallel tests still run one at a time, but use the same make instructions as serial tests. Platforms tested: mir, eirene, sleipnir, pommier, copper, modi4 (some errors occurred, probably due to the test being run before updating hdf5. Will re-run tests after checkin.)
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 52dee19..83e71e8 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -55,7 +55,7 @@ DISTCLEANFILES=h5fc libhdf5_fortran.settings
# H5fortran_types.f90 and H5f90i.h are automatically generaed by
# H5match_types, and must be cleaned explicitly. H5fort_type_defines.h
# is generated by H5fortran_detect
-MOSTLYCLEANFILES=H5fortran_types.f90 H5f90i_gen.h H5fort_type_defines.h \
+MOSTLYCLEANFILES+=H5fortran_types.f90 H5f90i_gen.h H5fort_type_defines.h \
H5fortran_detect.f90
# Fortran module files can have different extensions and different names