summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2008-05-19 05:06:51 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2008-05-19 05:06:51 (GMT)
commitca94c839d55e383f541c9713e0a0aa085a0572af (patch)
treed0ec359b7855d254734ea7c5cc9d6bde383add62 /fortran/src/Makefile.am
parent2adc43f81221954e16da3338445323f1e4d958ad (diff)
downloadhdf5-ca94c839d55e383f541c9713e0a0aa085a0572af.zip
hdf5-ca94c839d55e383f541c9713e0a0aa085a0572af.tar.gz
hdf5-ca94c839d55e383f541c9713e0a0aa085a0572af.tar.bz2
[svn-r15036] Bug fix.
Description: The fortran Makefile.am used HDF_FORTRAN to indicate it is part of the Fortran API source so that conclude.am will give fortran api prefix in the test output. The symbox HDF_FORTRAN is also used in configure for a different purpose (indicated --enable-fortran). They conflicted. Similar problem for the symbol HDF_CXX. Solution: Changed all the involved Makefile.am to use "FORTRAN_API" instead. It is a more appropriate name. Same for CXX_API. Along the way, discovered that the Makefile.am of hl/fortran/test and hl/cxx/test did not have those symbols at all. Added them in. Platform tested: Kagiso only. It is a trivia change.
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 4216f34..47caf20 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -149,7 +149,7 @@ H5fortran_detect.f90: H5test_kind$(EXEEXT)
H5test_kind_SOURCES = $(srcdir)/H5test_kind.f90
# Mark this directory as part of the Fortran API
-HDF_FORTRAN=yes
+FORTRAN_API=yes
# Hardcode the dependencies of these files. There isn't a known way of
# determining this automagically (like we do with the C files). So, when