summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-05-26 14:44:12 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-05-26 14:44:12 (GMT)
commite3dce488c9325f331b79cbf6b1c013213612470c (patch)
treee3d389bab90655682ed272570a015d7f78774422 /fortran/src/Makefile.am
parent6ffdaca0161bcc9f785d7d3c79ae9835998e4465 (diff)
downloadhdf5-e3dce488c9325f331b79cbf6b1c013213612470c.zip
hdf5-e3dce488c9325f331b79cbf6b1c013213612470c.tar.gz
hdf5-e3dce488c9325f331b79cbf6b1c013213612470c.tar.bz2
[svn-r12379] Purpose:
Bug fix Description: tg-login was having an error about H5match_types.Tpo being missing. Solution: tg-login was trying to build H5_match_types twice at the same time and becoming confused as a result. Massaged the dependencies in the Makefile.am to prevent this. Platforms tested: mir, sol, tg-login
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 6188359..3195fc8 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -21,7 +21,7 @@ include $(top_srcdir)/config/commence.am
# Include src directory in both Fortran and C flags (C compiler is used
# for linking).
-INCLUDES += -I$(top_srcdir)/src
+INCLUDES+=-I$(top_srcdir)/src
AM_FCFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/fortran/src
AM_FCLIBS=$(LIBHDF5)
@@ -125,8 +125,7 @@ BUILT_SOURCES = H5f90i_gen.h
#Specify what Automake needs to create: first the H5fort_type_defines.h
# header, then H5match_types which includes that header, then
# it needs to run H5match_types.
-H5fortran_types.f90 H5f90i_gen.h: H5match_types.c H5fort_type_defines.h
- $(MAKE) $(AM_MAKEFLAGS) H5match_types$(EXEEXT)
+H5fortran_types.f90 H5f90i_gen.h: H5match_types$(EXEEXT)
$(RUNSERIAL) ./H5match_types$(EXEEXT)
# H5fort_type_defines.h is created by running H5fortran_detect.
@@ -134,6 +133,8 @@ H5fortran_types.f90 H5f90i_gen.h: H5match_types.c H5fort_type_defines.h
H5fort_type_defines.h: H5fortran_detect$(EXEEXT)
$(RUNSERIAL) ./H5fortran_detect$(EXEEXT) > H5fort_type_defines.h
+H5match_types.$(OBJEXT): H5fort_type_defines.h
+
# Automake knows how to build fortran programs if we tell it the source
# files.
H5fortran_detect_SOURCES = H5fortran_detect.f90