summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2008-05-20 01:29:26 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2008-05-20 01:29:26 (GMT)
commit4344cf539168e127f87c6f86171bc3cbd66e4032 (patch)
tree0a37970e35bf7156347d178fd809a9cb566fe4d6 /fortran/src/Makefile.am
parent6631ced7a910a7fd9b7752faae0b1321979dd009 (diff)
downloadhdf5-4344cf539168e127f87c6f86171bc3cbd66e4032.zip
hdf5-4344cf539168e127f87c6f86171bc3cbd66e4032.tar.gz
hdf5-4344cf539168e127f87c6f86171bc3cbd66e4032.tar.bz2
[svn-r15042] Bug fix.
Description: The fortran Makefile.am used HDF_FORTRAN to indicate it is part of the Fortran API source so that conclude.am will give fortran api prefix in the test output. The symbox HDF_FORTRAN is also used in configure for a different purpose (indicated --enable-fortran). They conflicted. Similar problem for the symbol HDF_CXX. Solution: Changed all the involved Makefile.am to use "FORTRAN_API" instead. It is a more appropriate name. Same for CXX_API. Along the way, discovered that the Makefile.am of hl/fortran/test and hl/cxx/test did not have those symbols at all. Added them in. Platform tested: Kagiso serial and h5committested (kagisopp, smirom, linew).
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 4216f34..47caf20 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -149,7 +149,7 @@ H5fortran_detect.f90: H5test_kind$(EXEEXT)
H5test_kind_SOURCES = $(srcdir)/H5test_kind.f90
# Mark this directory as part of the Fortran API
-HDF_FORTRAN=yes
+FORTRAN_API=yes
# Hardcode the dependencies of these files. There isn't a known way of
# determining this automagically (like we do with the C files). So, when