summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2014-07-18 22:17:58 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2014-07-18 22:17:58 (GMT)
commit442f9854645775a2bc7b20efe2170fb5a15ea29b (patch)
treebe5df249ef8c9d178797bc1be422f251192de8cf /fortran/src/Makefile.am
parentb79ca69a25aa612a97bc0aaa13710a2bf27a6376 (diff)
downloadhdf5-442f9854645775a2bc7b20efe2170fb5a15ea29b.zip
hdf5-442f9854645775a2bc7b20efe2170fb5a15ea29b.tar.gz
hdf5-442f9854645775a2bc7b20efe2170fb5a15ea29b.tar.bz2
[svn-r25433] Brought changes from the trunk into the branch.
For the top level, brings in changes for configure.ac, configure and the MANIFEST: svn merge -c25286 https://svn.hdfgroup.uiuc.edu/hdf5/trunk . svn merge -c25287 https://svn.hdfgroup.uiuc.edu/hdf5/trunk . svn merge -c25290 https://svn.hdfgroup.uiuc.edu/hdf5/trunk . For the fortran level: 384 17:00 svn merge -r25235:25272 https://svn.hdfgroup.uiuc.edu/hdf5/trunk/fortran 389 17:01 svn merge -r25284:25432 https://svn.hdfgroup.uiuc.edu/hdf5/trunk/fortran For the fortran merges, I skipped changes relating to hyperslab selection since the C source has not been merged from the trunk yet. These changes should be in place in the fortran source when the C source is merged to the 1.8 branch.
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index af0e6ee..a4b3843 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -176,11 +176,15 @@ H5fortran_detect.f90: H5test_kind$(EXEEXT)
# H5test_kind.f90 is included in the distribution, and Automake knows
# how to compile a fortran program given its sources.
+if FORTRAN_HAVE_STORAGE_SIZE
+ H5test_kind_SOURCES = H5test_kind_STORAGE_SIZE.f90
+else
if FORTRAN_HAVE_SIZEOF
H5test_kind_SOURCES = H5test_kind_SIZEOF.f90
else
H5test_kind_SOURCES = H5test_kind.f90
endif
+endif
# Mark this directory as part of the Fortran API
FORTRAN_API=yes