summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-28 22:54:17 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-28 22:54:17 (GMT)
commit5b4232e9d164434e422bdd72199f39507af984d8 (patch)
treef872924dd1d0d6f1059cf99a48317933b341286b /fortran/src/Makefile.am
parent08bce1b7d2969ccb08ad4ba963ec6f17f57e9728 (diff)
downloadhdf5-5b4232e9d164434e422bdd72199f39507af984d8.zip
hdf5-5b4232e9d164434e422bdd72199f39507af984d8.tar.gz
hdf5-5b4232e9d164434e422bdd72199f39507af984d8.tar.bz2
[svn-r10107] Purpose:
Bug fix Description: Fortran builds were dying with unknown flags. Solution: Fortran builds should be static, not shared. Static flags had been specified for libraries, but apparently were also needed for executables. Solved problem by adding static flag to everything in fortran directories. Platforms tested: mir, eirene
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index b7445d4..351ecbd 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -24,12 +24,12 @@ include $(top_srcdir)/config/commence.am
INCLUDES = -I$(top_srcdir)/src
AM_FFLAGS=-I$(top_srcdir)/src
+# Fortran libraries are linked statically to solve a build problem.
+AM_LDFLAGS=-static
+
# This is our main target, the fortran library
lib_LTLIBRARIES=libhdf5_fortran.la
-# Fortran library is linked statically to solve a build problem.
-libhdf5_fortran_la_LDFLAGS=-static
-
# Include HDF5.f90 if parallel is disabled, HDF5mpiof* if parallel is enabled
if BUILD_PARALLEL_CONDITIONAL
PARALLEL_COND_SRC = H5FDmpiof.c HDF5mpio.f90 H5FDmpioff.f90