summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-07-21 19:28:11 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-07-21 19:28:11 (GMT)
commit7236935a9d666926b5843f317a84743ef3d4126a (patch)
tree21d7f4f7d0fbc1348c374ba39f9b2ca095841e81 /fortran/src/Makefile.am
parentbb31e94a924a1b3f6f1da6c10ffe95029c87d5c5 (diff)
downloadhdf5-7236935a9d666926b5843f317a84743ef3d4126a.zip
hdf5-7236935a9d666926b5843f317a84743ef3d4126a.tar.gz
hdf5-7236935a9d666926b5843f317a84743ef3d4126a.tar.bz2
[svn-r11095] Purpose:
Configuration feature Description: Serial test output is now stored in log files and printed when all tests in a directory complete, or when a test fails. This should make test output more readable and useful. Also made changes to clean up ii_files directories that are created by some C++ compilers/linkers. Also fixed a few minor Makefile bugs. Solution: When serial tests run, their output is saved in *.log or *.logsh. While running, tests only print when they begin and when they complete; their more specific output (from the log file) is printed if the test fails or when all tests have completed. Comments welcome. Platforms tested: mir, modi4 (parallel and serial), copper, shanti
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 83e71e8..cc46d1c 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -20,9 +20,9 @@
include $(top_srcdir)/config/commence.am
# Include src directory in both Fortran and C flags (C compiler is used
-# for linking)
+# for linking).
INCLUDES = -I$(top_srcdir)/src
-AM_FCFLAGS=-I$(top_srcdir)/src
+AM_FCFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/src/fortran
AM_FCLIBS=$(LIBHDF5)
@@ -124,11 +124,6 @@ H5fortran_types.f90 H5f90i_gen.h: H5match_types.c H5fort_type_defines.h
$(MAKE) $(AM_MAKEFLAGS) H5match_types$(EXEEXT)
$(RUNSERIAL) ./H5match_types$(EXEEXT)
-
-# JAMES: does it need to work like this? $(MAKE) $(AM_MAKEFLAGS) H5fort_type_defines.h
-# JAMES $(MAKE) $(AM_MAKEFLAGS) H5match_types$(EXEEXT)
-# JAMES $(RUNSERIAL) ./H5match_types$(EXEEXT)
-
# H5fort_type_defines.h is created by running H5fortran_detect.
# Obviously, H5fortran_detect needs to be built first.
H5fort_type_defines.h: H5fortran_detect$(EXEEXT)