summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2008-10-08 05:17:05 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2008-10-08 05:17:05 (GMT)
commit73bf21ce054cd67bf895bcab462d7b3e9c0bc996 (patch)
treec058610cdbe8d810fd07a5919ea1f8d7ceca2fcc /fortran/src/Makefile.am
parentf1e2853e6f252c99d7a55c59f4611f9d2f82975b (diff)
downloadhdf5-73bf21ce054cd67bf895bcab462d7b3e9c0bc996.zip
hdf5-73bf21ce054cd67bf895bcab462d7b3e9c0bc996.tar.gz
hdf5-73bf21ce054cd67bf895bcab462d7b3e9c0bc996.tar.bz2
[svn-r15812] Bug fix: #1090
The custom rules for installing h5cc, h5fc, and the fortran modules in fortran and in hl/fortran don't use $(DESTDIR). Added it to all those rules. Tested: kagiso both serial and parallel with fortran and cxx enabled. Tested by: make install make DESTDIR=/tmp/acheng install diff -r /tmp/acheng/.../hdf5 hdf5
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 2f8e841..6da0883 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -89,20 +89,20 @@ clean-local:
install-data-local:
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
- $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
+ $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(DESTDIR)$(includedir)/. ; \
fi
uninstall-local:
@if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(includedir)/HDF5.$(F9XMODEXT)"; then \
- set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
+ set -x; $(RM) $(DESTDIR)$(includedir)/*.$(F9XMODEXT); \
fi; \
fi; \
- $(RM) $(bindir)/$(H5FC_NAME)
+ $(RM) $(DESTDIR)$(bindir)/$(H5FC_NAME)
# Also install and uninstall (uninstall-local above) h5fc script
install-exec-local:
- @$(INSTALL) h5fc $(bindir)/$(H5FC_NAME)
+ @$(INSTALL) h5fc $(DESTDIR)$(bindir)/$(H5FC_NAME)
# Install libhdf5_fortran.settings in lib directory
settingsdir=$(libdir)