summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-09-15 21:30:06 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-09-15 21:30:06 (GMT)
commitcc8f7d98bf0a373e397faecd14e3480cf5c0777d (patch)
tree293f1fe8128713c4e30c5ac068a0a3d7077e8521 /fortran/src/Makefile.am
parent7c3f0740877f30683d9492b97fee97a780d9dd7f (diff)
downloadhdf5-cc8f7d98bf0a373e397faecd14e3480cf5c0777d.zip
hdf5-cc8f7d98bf0a373e397faecd14e3480cf5c0777d.tar.gz
hdf5-cc8f7d98bf0a373e397faecd14e3480cf5c0777d.tar.bz2
[svn-r11418] Purpose:
Bug fix/feature Description: Disabled shared libraries for a number of Fortran compilers that don't support them. This allows other compilers to support shared Fortran libraries. Solution: Added a conditional, SHARED_FORTRAN_CONDITIONAL, which is true if Fortran supports shared libraries. It is set in configure.in. Platforms tested: mir, sleipnir, colonelk, heping
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 9b83a9d..266186f 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -29,6 +29,14 @@ AM_FCLIBS=$(LIBHDF5)
# This is our main target, the fortran library
lib_LTLIBRARIES=libhdf5_fortran.la
+# Some Fortran compilers can't build shared libraries, so sometimes we
+# want to build a shared C library and a static Fortran library. If so,
+# pass the -static flag to the library linker.
+if FORTRAN_SHARED_CONDITIONAL
+else
+ AM_LDFLAGS=-static
+endif
+
# Include HDF5.f90 if parallel is disabled, HDF5mpiof* if parallel is enabled
if BUILD_PARALLEL_CONDITIONAL
PARALLEL_COND_SRC = H5FDmpiof.c HDF5mpio.f90 H5FDmpioff.f90