summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-26 22:28:23 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-26 22:28:23 (GMT)
commitd7883f21bf2d0d4b7b21397b42520a381364f30f (patch)
tree66d858b5a1b1d44f2db1e7f3b240eb679fcf8367 /fortran/src/Makefile.am
parenta9b7b7d971cc714e09647794a2d688463c507666 (diff)
downloadhdf5-d7883f21bf2d0d4b7b21397b42520a381364f30f.zip
hdf5-d7883f21bf2d0d4b7b21397b42520a381364f30f.tar.gz
hdf5-d7883f21bf2d0d4b7b21397b42520a381364f30f.tar.bz2
[svn-r10098] Purpose:
Bug fix Description: Some machines and compilers were having trouble creating fortran libraries as shared libraries. Solution: Added flag in Makefiles.am to create fortran libraries as shared libraries. (This is how HDF5 was set up before automake changes; I forgot to add these flags, and it didn't cause a problem until now.) Platforms tested: sleipnir, eirene, verbena Misc. update:
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index f2ffc1b..b7445d4 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -27,7 +27,7 @@ AM_FFLAGS=-I$(top_srcdir)/src
# This is our main target, the fortran library
lib_LTLIBRARIES=libhdf5_fortran.la
-# DEBUG - will linking statically solve fortran build problem?
+# Fortran library is linked statically to solve a build problem.
libhdf5_fortran_la_LDFLAGS=-static
# Include HDF5.f90 if parallel is disabled, HDF5mpiof* if parallel is enabled