summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-10-15 17:08:41 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-10-15 17:08:41 (GMT)
commitdd4360dccfda32f477192bd4a4ee22ee24585cf0 (patch)
tree1a6d58a5ddaa88dfdac2e558e0ea65f38da73581 /fortran/src/Makefile.am
parent2a2a49f42280220ad7cf2c45b1e5103d3b72146a (diff)
downloadhdf5-dd4360dccfda32f477192bd4a4ee22ee24585cf0.zip
hdf5-dd4360dccfda32f477192bd4a4ee22ee24585cf0.tar.gz
hdf5-dd4360dccfda32f477192bd4a4ee22ee24585cf0.tar.bz2
[svn-r17645] Purpose:
Merge from Trunk Description: Merging all of my CFLAGS-related changes from trunk to 1.8 This includes revision #s: 17616, 17625, 17627, 17639, and 17643. Tested: h5committest and some additional checks on our FreeBSD as well as NCSA's machines.
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 3a9c3f2..d2644a1 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -24,7 +24,7 @@ include $(top_srcdir)/config/lt_vers.am
# Include src directory in both Fortran and C flags (C compiler is used
# for linking).
INCLUDES=-I$(top_srcdir)/src
-AM_FCFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/fortran/src
+AM_FCFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/fortran/src
AM_FCLIBS=$(LIBHDF5)
@@ -32,14 +32,14 @@ AM_FCLIBS=$(LIBHDF5)
lib_LTLIBRARIES=libhdf5_fortran.la
# Add libtool numbers to the HDF5 Fortran library (from config/lt_vers.am)
-libhdf5_fortran_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE)
+libhdf5_fortran_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
# Some Fortran compilers can't build shared libraries, so sometimes we
# want to build a shared C library and a static Fortran library. If so,
# pass the -static flag to the library linker.
if FORTRAN_SHARED_CONDITIONAL
else
- AM_LDFLAGS=-static
+ AM_LDFLAGS+=-static
endif
# Include HDF5.f90 if parallel is disabled, HDF5mpiof* if parallel is enabled