summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2015-07-16 13:59:21 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2015-07-16 13:59:21 (GMT)
commit53b3d666e5069ff65db1f739b7f0eb3634032b58 (patch)
tree9ed01a92126832c2581bc143c34e7f6e2ed41ef0 /fortran/src/Makefile.am
parent08244fb237c774129fe6b17e9021a8447fe8797b (diff)
downloadhdf5-53b3d666e5069ff65db1f739b7f0eb3634032b58.zip
hdf5-53b3d666e5069ff65db1f739b7f0eb3634032b58.tar.gz
hdf5-53b3d666e5069ff65db1f739b7f0eb3634032b58.tar.bz2
[svn-r27399] code clean-up
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am20
1 files changed, 3 insertions, 17 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 3333ae6..734f46e 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -106,9 +106,8 @@ endif
# programs.
# It's a bit tricky to make sure that Automake builds things in the right
# order (especially when using 'gmake -j ...')
-# H5_buildiface is compiled and run to produce H5KIND***.
-# H5fortran_detect is compiled and run to produce H5fort_type_defines.h.
-# H5match_types.c then includes this file and can be compiled into
+# H5_buildiface is compiled and run to produce H5_gen.F90.
+# H5match_types.c then includes H5fort_type_defines.h and can be compiled into
# H5match_types. When H5match_types is run, it creates H5f90i_gen.h
# and H5fortran_types.F90, which are included in the Fortran library.
@@ -126,17 +125,6 @@ BUILT_SOURCES = H5f90i_gen.h
H5fortran_types.F90 H5f90i_gen.h: H5match_types$(EXEEXT)
$(RUNSERIAL) ./H5match_types$(EXEEXT)
-# H5fort_type_defines.h is created by running H5fortran_detect.
-# Obviously, H5fortran_detect needs to be built first.
-#H5fort_type_defines.h: H5fortran_detect$(EXEEXT)
-# $(RUNSERIAL) ./H5fortran_detect$(EXEEXT) > H5fort_type_defines.h
-
-#H5match_types.$(OBJEXT): H5fort_type_defines.h
-
-# Automake knows how to build fortran programs if we tell it the source
-# files.
-#H5fortran_detect_SOURCES = H5fortran_detect.F90
-
# H5_buildiface.F90 generates all the APIs that have a KIND type associated
# with them.
@@ -156,9 +144,7 @@ FORTRAN_API=yes
# doing a parallel make, some modules could be made way before the
# modules they depend upon are actually made. *sigh*
H5f90global.lo: $(srcdir)/H5f90global.F90 H5fortran_types.lo
-#H5fortran_types.lo: H5fortran_types.F90
-#H5fortran_detect.lo: H5fortran_detect.F90
-H5_buildiface.lo: $(srcdir)/H5_buildiface.F90
+H5_buildiface.lo: $(srcdir)/H5_buildiface.F90
H5_ff.lo: $(srcdir)/H5_ff.F90 H5f90global.lo
H5Aff.lo: $(srcdir)/H5Aff.F90 H5f90global.lo
H5Dff.lo: $(srcdir)/H5Dff.F90 H5f90global.lo