summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2014-04-25 21:59:53 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2014-04-25 21:59:53 (GMT)
commitc6e3e682973aa793844e39376cb7ada93ce505ba (patch)
tree190929e40042c15843c28d591a1c0e336c743dc4 /fortran/src/Makefile.am
parent7309bb5ab8810a701d5aa98c8068b98792585d9a (diff)
downloadhdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.zip
hdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.tar.gz
hdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.tar.bz2
[svn-r25117] Removed LT_ADD_LIBHDF5_DEPENDENCY configure conditional to roll back fix for removing rpaths from l
ib files. The fix also removed dependencies on libhdf5, etc. when the --disable-sharedlib-rpath co nfigure option was invoked. Added instead configure variable hardcode_into_lib=no. This removes rpath from lib files on Linux and solaris machines. Tested with h5committest on jam, koala, ostrich and platypus (cmake), and with configure option --disable-sharedlib-rpath on emu, platypus and quail.
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 5e190a2..af0e6ee 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -79,11 +79,8 @@ libhdf5_fortran_la_SOURCES=H5f90global.f90 \
H5Aff$(F_STATUS).f90 H5Dff$(F_STATUS).f90 H5Eff$(F_STATUS).f90 H5Fff$(F_STATUS).f90 H5Lff$(F_STATUS).f90 \
H5Off$(F_STATUS).f90 H5Pff$(F_STATUS).f90 H5Rff$(F_STATUS).f90 H5Tff$(F_STATUS).f90 $(PARALLEL_COND_SRC)
-# HDF5 Fortran library depends on HDF5 Library. However, only add the dependency
-# if --enable-sharedlib-rpath is yes.
-if LT_ADD_LIBHDF5_DEPENDENCY
+# HDF5 Fortran library depends on HDF5 Library.
libhdf5_fortran_la_LIBADD=$(LIBHDF5)
-endif
# h5fc is generated during configure.
# Remove it only when distclean.