summaryrefslogtreecommitdiffstats
path: root/fortran/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2016-04-19 19:45:07 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2016-04-19 19:45:07 (GMT)
commitb38491a7c2580661ea7117b093799d49c93e34c7 (patch)
treebd8ea5a2ec4312fb0ab5e15e82babb04cecc7eaa /fortran/test/CMakeLists.txt
parent32ff3431c7ebc3be08659008f27008e470bf0c8d (diff)
downloadhdf5-b38491a7c2580661ea7117b093799d49c93e34c7.zip
hdf5-b38491a7c2580661ea7117b093799d49c93e34c7.tar.gz
hdf5-b38491a7c2580661ea7117b093799d49c93e34c7.tar.bz2
[svn-r29748] HDFFV-9770: Fix h5watch and CMake for HL.
Convert CMake sources tags from _SRCS to _SOURCES(closer match to Makefile).
Diffstat (limited to 'fortran/test/CMakeLists.txt')
-rw-r--r--fortran/test/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/fortran/test/CMakeLists.txt b/fortran/test/CMakeLists.txt
index 005a5c8..d1ca6e8 100644
--- a/fortran/test/CMakeLists.txt
+++ b/fortran/test/CMakeLists.txt
@@ -75,7 +75,7 @@ if (BUILD_SHARED_LIBS AND NOT SKIP_HDF5_FORTRAN_SHARED)
)
endif (BUILD_SHARED_LIBS AND NOT SKIP_HDF5_FORTRAN_SHARED)
-set (HDF5_F90_TF_SRCS
+set (HDF5_F90_TF_SOURCES
# generated files
${HDF5_F90_BINARY_DIR}/tf_gen.F90
)
@@ -83,7 +83,7 @@ set_source_files_properties (
${HDF5_F90_BINARY_DIR}/tf_gen.F90
PROPERTIES GENERATED TRUE
)
-set_source_files_properties (tf.F90 ${HDF5_F90_BINARY_DIR}/${HDF5_F90_TF_SRCS} PROPERTIES LANGUAGE Fortran)
+set_source_files_properties (tf.F90 ${HDF5_F90_BINARY_DIR}/${HDF5_F90_TF_SOURCES} PROPERTIES LANGUAGE Fortran)
set (CMD $<TARGET_FILE:H5_test_buildiface>)
add_custom_target (H5testgen ALL
@@ -93,9 +93,9 @@ add_custom_target (H5testgen ALL
DEPENDS H5_test_buildiface
)
-add_library (${HDF5_F90_TEST_LIB_TARGET} STATIC tf.F90 ${HDF5_F90_TF_SRCS})
+add_library (${HDF5_F90_TEST_LIB_TARGET} STATIC tf.F90 ${HDF5_F90_TF_SOURCES})
if (BUILD_SHARED_LIBS AND NOT SKIP_HDF5_FORTRAN_SHARED)
- add_library (${HDF5_F90_TEST_LIBSH_TARGET} SHARED tf.F90 ${HDF5_F90_TF_SRCS})
+ add_library (${HDF5_F90_TEST_LIBSH_TARGET} SHARED tf.F90 ${HDF5_F90_TF_SOURCES})
endif (BUILD_SHARED_LIBS AND NOT SKIP_HDF5_FORTRAN_SHARED)
TARGET_FORTRAN_PROPERTIES (${HDF5_F90_TEST_LIB_TARGET} STATIC " " " ")