summaryrefslogtreecommitdiffstats
path: root/fortran/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-01-30 18:29:51 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-01-30 18:29:51 (GMT)
commit0866bc0bb855fcfdde4608cc437c29d668634a67 (patch)
treea388fc51aaa5106db227555434d13cc090d98d5d /fortran/test/CMakeLists.txt
parent2f18da435e537118e1405f7f9fef3f3e29a346f2 (diff)
downloadhdf5-0866bc0bb855fcfdde4608cc437c29d668634a67.zip
hdf5-0866bc0bb855fcfdde4608cc437c29d668634a67.tar.gz
hdf5-0866bc0bb855fcfdde4608cc437c29d668634a67.tar.bz2
HDFFV-10398 use the target name for custom commands
Diffstat (limited to 'fortran/test/CMakeLists.txt')
-rw-r--r--fortran/test/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/fortran/test/CMakeLists.txt b/fortran/test/CMakeLists.txt
index 2990bcc..86f7a12 100644
--- a/fortran/test/CMakeLists.txt
+++ b/fortran/test/CMakeLists.txt
@@ -74,10 +74,9 @@ if (BUILD_SHARED_LIBS)
)
endif ()
-set (CMD $<TARGET_FILE:H5_test_buildiface>)
add_custom_command (
OUTPUT ${HDF5_FORTRAN_TESTS_BINARY_DIR}/static/tf_gen.F90
- COMMAND ${CMD}
+ COMMAND $<TARGET_FILE:H5_test_buildiface>
WORKING_DIRECTORY ${HDF5_FORTRAN_TESTS_BINARY_DIR}/static
DEPENDS H5_test_buildiface
COMMENT "Generating the tf_gen.F90 file"
@@ -88,10 +87,9 @@ add_custom_target (H5testgen ALL
set_source_files_properties (${HDF5_FORTRAN_TESTS_BINARY_DIR}/static/tf_gen.F90 PROPERTIES GENERATED TRUE)
if (BUILD_SHARED_LIBS)
- set (CMDSH $<TARGET_FILE:H5_test_buildiface>)
add_custom_command (
OUTPUT ${HDF5_FORTRAN_TESTS_BINARY_DIR}/shared/tf_gen.F90
- COMMAND ${CMDSH}
+ COMMAND $<TARGET_FILE:H5_test_buildiface>
WORKING_DIRECTORY ${HDF5_FORTRAN_TESTS_BINARY_DIR}/shared
DEPENDS H5_test_buildiface
COMMENT "Generating the tf_gen.F90 shared file"