summaryrefslogtreecommitdiffstats
path: root/fortran/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-02-04 17:28:45 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-02-04 17:28:45 (GMT)
commit3ec66d55426c5c947eeb6f4d7d5d31b38f59ebf6 (patch)
tree4699bb6a3e51744775edb0c726282f28f4b2a372 /fortran/test/CMakeLists.txt
parent00d68851fcd1dbfcd70966bfaff22085de9b1634 (diff)
downloadhdf5-3ec66d55426c5c947eeb6f4d7d5d31b38f59ebf6.zip
hdf5-3ec66d55426c5c947eeb6f4d7d5d31b38f59ebf6.tar.gz
hdf5-3ec66d55426c5c947eeb6f4d7d5d31b38f59ebf6.tar.bz2
HDFFV-11012 - add correct fortran include path properties
Diffstat (limited to 'fortran/test/CMakeLists.txt')
-rw-r--r--fortran/test/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/test/CMakeLists.txt b/fortran/test/CMakeLists.txt
index 3c46c9e..a3cc552 100644
--- a/fortran/test/CMakeLists.txt
+++ b/fortran/test/CMakeLists.txt
@@ -132,7 +132,7 @@ if (NOT BUILD_SHARED_LIBS)
PRIVATE
"${CMAKE_Fortran_MODULE_DIRECTORY}/static;${HDF5_F90_BINARY_DIR};${HDF5_F90_BINARY_DIR}/static"
INTERFACE
- "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include>"
+ "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include/static>"
)
target_compile_definitions(${HDF5_F90_TEST_LIB_TARGET}
PRIVATE
@@ -165,7 +165,7 @@ else ()
PRIVATE
"${CMAKE_Fortran_MODULE_DIRECTORY}/shared;${HDF5_F90_BINARY_DIR};${HDF5_F90_BINARY_DIR}/shared"
INTERFACE
- "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include>"
+ "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include/shared>"
)
target_compile_definitions(${HDF5_F90_TEST_LIBSH_TARGET}
PUBLIC