summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorM. Scot Breitenfeld <brtnfld@hdfgroup.org>2016-09-26 16:49:06 (GMT)
committerM. Scot Breitenfeld <brtnfld@hdfgroup.org>2016-09-26 16:49:06 (GMT)
commit7e5fcd3a4a4f4949505b47d48d0292e944b3e670 (patch)
tree1e980f07a0539e4027c1303d95fbce57f1d10585 /fortran/test/Makefile.am
parentc06993b5b78b5f2594e58d1d3acd16017916acae (diff)
downloadhdf5-7e5fcd3a4a4f4949505b47d48d0292e944b3e670.zip
hdf5-7e5fcd3a4a4f4949505b47d48d0292e944b3e670.tar.gz
hdf5-7e5fcd3a4a4f4949505b47d48d0292e944b3e670.tar.bz2
Added rule to build buildiface program, without a rule, build would add repeated compile options when using the NAG compiler.
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index 60f9f53..67b39e2 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -92,10 +92,14 @@ tf_gen.F90: H5_test_buildiface$(EXEEXT)
H5_test_buildiface_SOURCES = H5_test_buildiface.F90
-# The build of the H5_test_buildiface does depend on any libraries, so set it
+# The build of the H5_test_buildiface does not depend on any libraries, so set it
# to nothing.
-H5_test_buildiface_LDADD =
+H5_test_buildiface_LDADD =
+
+
+H5_test_buildiface$(EXEEXT): $(H5_test_buildiface_SOURCES)
+ $(FC) $(FCFLAGS) $< -o $@ -I.
# fflush2 depends on files created by fflush1
fflush2.chkexe_: fflush1.chkexe_