summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2008-05-23 17:08:30 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2008-05-23 17:08:30 (GMT)
commitac687db0208cac1007c4ac97f78802b3b4a609c6 (patch)
tree07f9d8ec24a6d27fc269e4b833d91dda67fbdaca /fortran/test/Makefile.am
parentef3b2df9752139ea4e1b855447d8509066f23800 (diff)
downloadhdf5-ac687db0208cac1007c4ac97f78802b3b4a609c6.zip
hdf5-ac687db0208cac1007c4ac97f78802b3b4a609c6.tar.gz
hdf5-ac687db0208cac1007c4ac97f78802b3b4a609c6.tar.bz2
[svn-r15069] Purpose:
Added code to remove module files when make clean Description: The module files were not being removed when make clean and caused compiling errors. fixed.
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index 4aa62cf..eeafeea 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -63,6 +63,30 @@ LDADD=libh5test_fortran.la $(LIBH5TEST) $(LIBH5F) $(LIBHDF5)
CHECK_CLEANFILES+=*.h5
MOSTLYCLEANFILES=*.tmp
+# Fortran module files can have different extensions and different names
+# (e.g., different capitalizations) on different platforms. Write rules
+# for them explicitly rather than trying to teach automake about them.
+# They should be installed as headers and removed during clean.
+maintainer-clean-local: clean-local
+distclean-local: clean-local
+clean-local:
+ @if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
+ $(RM) *.$(F9XMODEXT); \
+ fi
+
+install-data-local:
+ @if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
+ $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
+ fi
+
+uninstall-local:
+ @if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
+ if test -f "$(includedir)/tf.$(F9XMODEXT)" -o -f "$(includedir)/TF.$(F9XMODEXT)"; then \
+ set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
+ fi; \
+ fi; \
+ $(RM) $(bindir)/$(H5FC_NAME)
+
# Mark this directory as part of the Fortran API (this affects output
# from tests in conclude.am)
FORTRAN_API=yes
@@ -78,5 +102,6 @@ fortranlib_test.lo: $(srcdir)/fortranlib_test.f90 tf.lo
fortranlib_test_1_8.lo: $(srcdir)/fortranlib_test_1_8.f90 tf.lo
tH5A_1_8.lo: $(srcdir)/tH5A_1_8.f90 tf.lo
tH5G_1_8.lo: $(srcdir)/tH5G_1_8.f90 tf.lo
+tf.lo: $(srcdir)/t.f90
include $(top_srcdir)/config/conclude.am