summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-26 22:28:23 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-26 22:28:23 (GMT)
commitd7883f21bf2d0d4b7b21397b42520a381364f30f (patch)
tree66d858b5a1b1d44f2db1e7f3b240eb679fcf8367 /fortran/test/Makefile.am
parenta9b7b7d971cc714e09647794a2d688463c507666 (diff)
downloadhdf5-d7883f21bf2d0d4b7b21397b42520a381364f30f.zip
hdf5-d7883f21bf2d0d4b7b21397b42520a381364f30f.tar.gz
hdf5-d7883f21bf2d0d4b7b21397b42520a381364f30f.tar.bz2
[svn-r10098] Purpose:
Bug fix Description: Some machines and compilers were having trouble creating fortran libraries as shared libraries. Solution: Added flag in Makefiles.am to create fortran libraries as shared libraries. (This is how HDF5 was set up before automake changes; I forgot to add these flags, and it didn't cause a problem until now.) Platforms tested: sleipnir, eirene, verbena Misc. update:
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index 376a19e..b9f0b8d 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -26,6 +26,9 @@ INCLUDES=-I$(top_srcdir)/src
# The Fortran test library
lib_LTLIBRARIES=libh5test_fortran.la
+# Fortran library is linked statically to solve a build problem.
+libh5test_fortran_la_LDFLAGS=-static
+
# Our main targets, the tests themselves
TEST_PROG=fortranlib_test fflush1 fflush2
check_PROGRAMS=$(TEST_PROG)
@@ -34,8 +37,6 @@ libh5test_fortran_la_SOURCES=fortranlib_test.f90 tH5F.f90 tH5D.f90 \
tH5R.f90 tH5S.f90 tH5T.f90 tH5VL.f90 tH5Z.f90 tH5Sselect.f90 \
tH5P.f90 tH5A.f90 tH5I.f90 tH5G.f90 tH5E.f90 tf.f90 t.c
-libh5test_fortran_la_LDFLAGS=-static
-
# Source files are used for both the library and fortranlib_test.
# Automake will complain about this without the following workaround.
fortranlib_test_FFLAGS=$(AM_FFLAGS)