summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-03 21:59:40 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-03 21:59:40 (GMT)
commitdb2575baa91049ad4d5e5ea623ff1161443d1af2 (patch)
treec4169fb6dc29ddbcd8bc356afb98b708c96374dd /fortran/test/Makefile.am
parent51863989304a051ac6306c8c49c34d70a4cf992e (diff)
downloadhdf5-db2575baa91049ad4d5e5ea623ff1161443d1af2.zip
hdf5-db2575baa91049ad4d5e5ea623ff1161443d1af2.tar.gz
hdf5-db2575baa91049ad4d5e5ea623ff1161443d1af2.tar.bz2
[svn-r9930]
Purpose: Bug fix Description: Parallel builds were breaking in tools/lib Solution: talign didn't realize it depended on libh5tools.la because its dependencies listed the full path (../../tools/lib/libh5tools.la). Changed this, and made similar changes in a couple of other directories. This checkin should also add the --foreign flag to every Makefile.in Platforms tested: sleipnir (minor change)
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index 454e431..2aece4e 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -36,8 +36,6 @@ libh5test_fortran_la_SOURCES=fortranlib_test.f90 tH5F.f90 tH5D.f90 \
libh5test_fortran_la_LDFLAGS=-static
-##noinst_HEADERS=H5f90proto.h
-
# Source files are used for both the library and fortranlib_test.
# Automake will complain about this without the following workaround.
fortranlib_test_FFLAGS=$(AM_FFLAGS)
@@ -53,7 +51,7 @@ fflush2_SOURCES=fflush2.f90
# The fortran test library depends on the main fortran library.
# The tests depend on both fortran libraries and both main libraries.
LIBADD=$(LIBH5TEST) $(LIBHDF5) $(LIBH5F)
-LDADD=$(LIBH5FTEST) $(LIBH5TEST) $(LIBH5F) $(LIBHDF5)
+LDADD=libh5test_fortran.la $(LIBH5TEST) $(LIBH5F) $(LIBHDF5)
# Temporary files
MOSTLYCLEANFILES=*.h5 *.tmp