summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2014-04-07 16:29:23 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2014-04-07 16:29:23 (GMT)
commitf6a04cded9e3ec9d2c672215c8ab7fffdec0a1ea (patch)
tree55a321401421a2fd35fe26cf24844af8bd021882 /fortran/test/Makefile.am
parentc520294d672a35f023c249fec057c8adc387673e (diff)
downloadhdf5-f6a04cded9e3ec9d2c672215c8ab7fffdec0a1ea.zip
hdf5-f6a04cded9e3ec9d2c672215c8ab7fffdec0a1ea.tar.gz
hdf5-f6a04cded9e3ec9d2c672215c8ab7fffdec0a1ea.tar.bz2
[svn-r24978] Removed the .mod (and .raw) files when make clean is issued.
tested (emu).
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index a9efb7f..9c6b906 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -79,9 +79,20 @@ fflush2_SOURCES=fflush2.f90
LDADD=libh5test_fortran.la $(LIBH5TEST) $(LIBH5F) $(LIBHDF5)
# Temporary files
-CHECK_CLEANFILES+=*.h5
+CHECK_CLEANFILES+=*.h5 *.raw
MOSTLYCLEANFILES=*.tmp
+# Fortran module files can have different extensions and different names
+# (e.g., different capitalizations) on different platforms. Write rules
+# for them explicitly rather than trying to teach automake about them.
+# They should be installed as headers and removed during clean.
+maintainer-clean-local: clean-local
+distclean-local: clean-local
+clean-local:
+ @if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
+ $(RM) *.$(F9XMODEXT); \
+ fi
+
# Mark this directory as part of the Fortran API (this affects output
# from tests in conclude.am)
FORTRAN_API=yes