summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2014-07-18 22:17:58 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2014-07-18 22:17:58 (GMT)
commit442f9854645775a2bc7b20efe2170fb5a15ea29b (patch)
treebe5df249ef8c9d178797bc1be422f251192de8cf /fortran/test/Makefile.am
parentb79ca69a25aa612a97bc0aaa13710a2bf27a6376 (diff)
downloadhdf5-442f9854645775a2bc7b20efe2170fb5a15ea29b.zip
hdf5-442f9854645775a2bc7b20efe2170fb5a15ea29b.tar.gz
hdf5-442f9854645775a2bc7b20efe2170fb5a15ea29b.tar.bz2
[svn-r25433] Brought changes from the trunk into the branch.
For the top level, brings in changes for configure.ac, configure and the MANIFEST: svn merge -c25286 https://svn.hdfgroup.uiuc.edu/hdf5/trunk . svn merge -c25287 https://svn.hdfgroup.uiuc.edu/hdf5/trunk . svn merge -c25290 https://svn.hdfgroup.uiuc.edu/hdf5/trunk . For the fortran level: 384 17:00 svn merge -r25235:25272 https://svn.hdfgroup.uiuc.edu/hdf5/trunk/fortran 389 17:01 svn merge -r25284:25432 https://svn.hdfgroup.uiuc.edu/hdf5/trunk/fortran For the fortran merges, I skipped changes relating to hyperslab selection since the C source has not been merged from the trunk yet. These changes should be in place in the fortran source when the C source is merged to the 1.8 branch.
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index c0b5395..735ab7a 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -53,7 +53,23 @@ endif
check_PROGRAMS=$(TEST_PROG)
-libh5test_fortran_la_SOURCES= tf.f90 t.c
+if FORTRAN_HAVE_STORAGE_SIZE
+if FORTRAN_HAVE_C_SIZEOF
+ libh5test_fortran_la_SOURCES = tf_F08.f90
+else
+ libh5test_fortran_la_SOURCES = tf_F03.f90
+endif
+else
+if FORTRAN_2003_CONDITIONAL_F
+ libh5test_fortran_la_SOURCES = tf_F03.f90
+else
+ libh5test_fortran_la_SOURCES = tf_F90.f90
+endif
+endif
+
+# tf.f90 depends on either tf_F08.f90 or tf_F03.f90 so they need to be
+# compiled first
+libh5test_fortran_la_SOURCES += tf.f90 t.c
# Source files are used for both the library and fortranlib_test.
# Automake will complain about this without the following workaround.