summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2016-08-16 18:26:26 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2016-08-16 18:26:26 (GMT)
commitb6c989a9173f0f9808a98ecfeb624870a7ab3c2c (patch)
tree89d18c95898adf1dcc26922b513aa925ab3e35cd /fortran/test/Makefile.am
parent62ad9411ba387e2b940ea0582ed7dc53e75d8ac5 (diff)
downloadhdf5-b6c989a9173f0f9808a98ecfeb624870a7ab3c2c.zip
hdf5-b6c989a9173f0f9808a98ecfeb624870a7ab3c2c.tar.gz
hdf5-b6c989a9173f0f9808a98ecfeb624870a7ab3c2c.tar.bz2
[svn-r30294] Removed the use of C_sizeof, since it causes issues with the NAG compiler.
Tested: jelly (gnu 4.8.3)
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index 735ab7a..95745e2 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -54,17 +54,13 @@ endif
check_PROGRAMS=$(TEST_PROG)
if FORTRAN_HAVE_STORAGE_SIZE
-if FORTRAN_HAVE_C_SIZEOF
libh5test_fortran_la_SOURCES = tf_F08.f90
else
+ if FORTRAN_2003_CONDITIONAL_F
libh5test_fortran_la_SOURCES = tf_F03.f90
-endif
-else
-if FORTRAN_2003_CONDITIONAL_F
- libh5test_fortran_la_SOURCES = tf_F03.f90
-else
- libh5test_fortran_la_SOURCES = tf_F90.f90
-endif
+ else
+ libh5test_fortran_la_SOURCES = tf_F90.f90
+ endif
endif
# tf.f90 depends on either tf_F08.f90 or tf_F03.f90 so they need to be