summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-07 17:57:27 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-07 17:57:27 (GMT)
commit25df1908bc0430994cecc9f1415838f42fe0c816 (patch)
treebce2777e087cc7d547e7b644f908eff72282bb53 /fortran/test/Makefile.am
parent630b2901c53c66c837e39babe9da0c20020e5d4d (diff)
downloadhdf5-25df1908bc0430994cecc9f1415838f42fe0c816.zip
hdf5-25df1908bc0430994cecc9f1415838f42fe0c816.tar.gz
hdf5-25df1908bc0430994cecc9f1415838f42fe0c816.tar.bz2
[svn-r10158] Purpose:
Automake version upgrade Description: Upgraded automake version from 1.6.2 to 1.9.5. Changed bin/reconfigure script to use automake 1.9.5. Changed configure.in and Makefiles to use new FCFLAGS and FC variables instead of FFLAGS and F9X. Automake and configure should now do the lion's share of the work supporting Fortran 9X; macros in acsite.m4 are now mostly unused (will be cleaned later). Altered how configure handles pmake; now root-level Makefile.in is processed by bin/reconfigure to have a .MAKEFLAGS target, since automake no longer allows us to define unused variables. Configure now always checks for C++ compiler even if it is not used, since automake thinks this is the Right Thing To Do and will break otherwise. Platforms tested: Sol, copper, heping, mir, sleipnir, eirene, pommier, kelgia, modi4.
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index ea9fd71..533458b 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -20,7 +20,7 @@
include $(top_srcdir)/config/commence.am
# Include files
-AM_FFLAGS=-I$(top_builddir)/fortran/src $(F9XMODFLAG)$(top_builddir)/fortran/src
+AM_FCFLAGS=-I$(top_builddir)/fortran/src $(F9XMODFLAG)$(top_builddir)/fortran/src
INCLUDES=-I$(top_srcdir)/src
# Fortran libraries are linked statically to solve a build problem.
@@ -39,7 +39,7 @@ libh5test_fortran_la_SOURCES=fortranlib_test.f90 tH5F.f90 tH5D.f90 \
# Source files are used for both the library and fortranlib_test.
# Automake will complain about this without the following workaround.
-fortranlib_test_FFLAGS=$(AM_FFLAGS)
+fortranlib_test_FCFLAGS=$(AM_FCFLAGS)
fortranlib_test_CFLAGS=$(AM_CFLAGS)
fortranlib_test_SOURCES = fortranlib_test.f90 \