summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-11 21:32:22 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-11 21:32:22 (GMT)
commitb96f342722a76cf3861f0d160f71aa3e5c3b7e88 (patch)
tree21808a536b1c38719684bd7bdd21fb325584c29d /fortran/test/Makefile.am
parent791146f98a08c90958fe5df3f546dddc7d341271 (diff)
downloadhdf5-b96f342722a76cf3861f0d160f71aa3e5c3b7e88.zip
hdf5-b96f342722a76cf3861f0d160f71aa3e5c3b7e88.tar.gz
hdf5-b96f342722a76cf3861f0d160f71aa3e5c3b7e88.tar.bz2
[svn-r9993] Purpose:
Bug fix Description: Arabica exhibited strange errors when linker found wrong versions of header files. This happened because include directories were given to linker in the wrong order. Solution: Move include directories from AM_CFLAGS variable to INCLUDES variable to put them before CPPFLAGS variable. Trust me, it works. This bug may also have contributed to strange errors on other platforms (kelgia?). Platforms tested: copper, sleipnir, arabica. (h5dump broke while building on arabica, but this happened in a clean checkout, too).
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index 2aece4e..6881f02 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -21,7 +21,7 @@ include $(top_srcdir)/config/commence.am
# Include files
AM_FFLAGS=-I$(top_builddir)/fortran/src $(F9XMODFLAG)$(top_builddir)/fortran/src
-AM_CFLAGS=-I$(top_srcdir)/src
+INCLUDES=-I$(top_srcdir)/src
# The Fortran test library
lib_LTLIBRARIES=libh5test_fortran.la
@@ -56,11 +56,11 @@ LDADD=libh5test_fortran.la $(LIBH5TEST) $(LIBH5F) $(LIBHDF5)
# Temporary files
MOSTLYCLEANFILES=*.h5 *.tmp
-# Fortran dependencies must be hardcoded, unfortunately.
-#FORTLIBTEST_OBJ= fortranlib_test.lo \
+## Fortran dependencies must be hardcoded, unfortunately.
+##FORTLIBTEST_OBJ= fortranlib_test.lo \
tH5F.lo tH5D.lo tH5R.lo tH5S.lo tH5T.lo tH5VL.lo tH5Z.lo \
tH5Sselect.lo tH5P.lo tH5A.lo tH5I.lo tH5G.lo tH5E.lo tf.lo \
t.lo
-#fortranlib_test$(EXEEXT): $(FORTLIBTEST_OBJ)
+##fortranlib_test$(EXEEXT): $(FORTLIBTEST_OBJ)
include $(top_srcdir)/config/conclude.am