summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2014-06-16 15:15:25 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2014-06-16 15:15:25 (GMT)
commit744bc7d236c18d65e9ac84e856f67e8ed145ef91 (patch)
tree7de2903b9bd1db3d387598ab47469e009db160e9 /fortran/test/Makefile.am
parent588a733b189d7410ccf4dc7da56ef81f2b11604f (diff)
downloadhdf5-744bc7d236c18d65e9ac84e856f67e8ed145ef91.zip
hdf5-744bc7d236c18d65e9ac84e856f67e8ed145ef91.tar.gz
hdf5-744bc7d236c18d65e9ac84e856f67e8ed145ef91.tar.bz2
[svn-r25286] Fix for:
HDFFV-8653 replace non-standard sizeof in the fortran tests with c_sizeof Tested: jam (gnu, intel) with make and cmake.
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index c0b5395..9a04106 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -53,7 +53,19 @@ endif
check_PROGRAMS=$(TEST_PROG)
-libh5test_fortran_la_SOURCES= tf.f90 t.c
+if FORTRAN_HAVE_STORAGE_SIZE
+if FORTRAN_HAVE_C_SIZEOF
+ libh5test_fortran_la_SOURCES = tf_F08.f90
+else
+ libh5test_fortran_la_SOURCES = tf_F03.f90
+endif
+else
+ libh5test_fortran_la_SOURCES = tf_F03.f90
+endif
+
+# tf.f90 depends on either tf_F08.f90 or tf_F03.f90 so they need to be
+# compiled first
+libh5test_fortran_la_SOURCES += tf.f90 t.c
# Source files are used for both the library and fortranlib_test.
# Automake will complain about this without the following workaround.