summaryrefslogtreecommitdiffstats
path: root/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorElena Pourmal <epourmal@hdfgroup.org>2008-05-27 16:06:23 (GMT)
committerElena Pourmal <epourmal@hdfgroup.org>2008-05-27 16:06:23 (GMT)
commitf15c901b8f95648603e1d10313d0b9b3b843d6b2 (patch)
tree8c8a34234db4698766ac7ed8ee963246a8b76377 /fortran/test/Makefile.am
parent887c7866935ae1b4ea261d02cbb52f381c94d389 (diff)
downloadhdf5-f15c901b8f95648603e1d10313d0b9b3b843d6b2.zip
hdf5-f15c901b8f95648603e1d10313d0b9b3b843d6b2.tar.gz
hdf5-f15c901b8f95648603e1d10313d0b9b3b843d6b2.tar.bz2
[svn-r15074] Maintenance: This check-in should fix daily tests failures:
Uninstall target had non-existant file to remove; error_handler module triggered a race condition for parallel make with Intel and PGI compilers, therefore we removed the module and created a subroutine instead. Platforms tested: kagiso with GNU, Intel and PGI compilers.
Diffstat (limited to 'fortran/test/Makefile.am')
-rw-r--r--fortran/test/Makefile.am33
1 files changed, 0 insertions, 33 deletions
diff --git a/fortran/test/Makefile.am b/fortran/test/Makefile.am
index 0c4d06c..ca0a1b4 100644
--- a/fortran/test/Makefile.am
+++ b/fortran/test/Makefile.am
@@ -63,30 +63,6 @@ LDADD=libh5test_fortran.la $(LIBH5TEST) $(LIBH5F) $(LIBHDF5)
CHECK_CLEANFILES+=*.h5
MOSTLYCLEANFILES=*.tmp
-# Fortran module files can have different extensions and different names
-# (e.g., different capitalizations) on different platforms. Write rules
-# for them explicitly rather than trying to teach automake about them.
-# They should be installed as headers and removed during clean.
-maintainer-clean-local: clean-local
-distclean-local: clean-local
-clean-local:
- @if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
- $(RM) *.$(F9XMODEXT); \
- fi
-
-install-data-local:
- @if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
- $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
- fi
-
-uninstall-local:
- @if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
- if test -f "$(includedir)/error_handler.$(F9XMODEXT)" -o -f "$(includedir)/ERROR_HANDLER.$(F9XMODEXT)"; then \
- set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
- fi; \
- fi; \
- $(RM) $(bindir)/$(H5FC_NAME)
-
# Mark this directory as part of the Fortran API (this affects output
# from tests in conclude.am)
FORTRAN_API=yes
@@ -94,14 +70,5 @@ FORTRAN_API=yes
# fflush2 depends on files created by fflush1
fflush2.chkexe_: fflush1.chkexe_
-# Hardcode the dependencies of these files. There isn't a known way of
-# determining this automagically (like we do with the C files). So, when
-# doing a parallel make, some modules could be made way before the
-# modules they depend upon are actually made. *sigh*
-fortranlib_test.lo: $(srcdir)/fortranlib_test.f90 tf.lo
-fortranlib_test_1_8.lo: $(srcdir)/fortranlib_test_1_8.f90 tf.lo
-tH5A_1_8.lo: $(srcdir)/tH5A_1_8.f90 tf.lo
-tH5G_1_8.lo: $(srcdir)/tH5G_1_8.f90 tf.lo
-tf.lo: $(srcdir)/tf.f90
include $(top_srcdir)/config/conclude.am