summaryrefslogtreecommitdiffstats
path: root/fortran/testpar/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-08-19 20:35:08 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-08-19 20:35:08 (GMT)
commit7470e8114d2fa875e84dba619b4c79c093c6f707 (patch)
tree3e6307091559520cc03a02781df53c24ca252ae0 /fortran/testpar/CMakeLists.txt
parent884dcbc7aa0005dc411bccada2339d38363cb8a6 (diff)
downloadhdf5-7470e8114d2fa875e84dba619b4c79c093c6f707.zip
hdf5-7470e8114d2fa875e84dba619b4c79c093c6f707.tar.gz
hdf5-7470e8114d2fa875e84dba619b4c79c093c6f707.tar.bz2
[svn-r27532] Merge of CMake dual-binary changes from CMake branch to 1.8
Tested: local linux (CMake branch has been tested on Windows)
Diffstat (limited to 'fortran/testpar/CMakeLists.txt')
-rw-r--r--fortran/testpar/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/fortran/testpar/CMakeLists.txt b/fortran/testpar/CMakeLists.txt
index 98ef6c8..4f21419 100644
--- a/fortran/testpar/CMakeLists.txt
+++ b/fortran/testpar/CMakeLists.txt
@@ -16,8 +16,8 @@ add_executable (parallel_test
hyper.f90
mdset.f90
)
-TARGET_NAMING (parallel_test ${LIB_TYPE})
-TARGET_FORTRAN_PROPERTIES (parallel_test ${LIB_TYPE} " " " ")
+TARGET_NAMING (parallel_test STATIC)
+TARGET_FORTRAN_PROPERTIES (parallel_test STATIC " " " ")
target_link_libraries (parallel_test
${HDF5_F90_TEST_LIB_TARGET}
${HDF5_F90_LIB_TARGET}
@@ -27,7 +27,7 @@ target_link_libraries (parallel_test
if (WIN32 AND MSVC)
target_link_libraries (parallel_test "ws2_32.lib")
endif (WIN32 AND MSVC)
-target_include_directories (parallel_test PRIVATE ${CMAKE_Fortran_MODULE_DIRECTORY})
+target_include_directories (parallel_test PRIVATE ${CMAKE_Fortran_MODULE_DIRECTORY}/static)
set_target_properties (parallel_test PROPERTIES LINKER_LANGUAGE Fortran)
set_target_properties (parallel_test PROPERTIES FOLDER test/fortran)