summaryrefslogtreecommitdiffstats
path: root/fortran/testpar/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-28 22:54:17 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-28 22:54:17 (GMT)
commit5b4232e9d164434e422bdd72199f39507af984d8 (patch)
treef872924dd1d0d6f1059cf99a48317933b341286b /fortran/testpar/Makefile.am
parent08bce1b7d2969ccb08ad4ba963ec6f17f57e9728 (diff)
downloadhdf5-5b4232e9d164434e422bdd72199f39507af984d8.zip
hdf5-5b4232e9d164434e422bdd72199f39507af984d8.tar.gz
hdf5-5b4232e9d164434e422bdd72199f39507af984d8.tar.bz2
[svn-r10107] Purpose:
Bug fix Description: Fortran builds were dying with unknown flags. Solution: Fortran builds should be static, not shared. Static flags had been specified for libraries, but apparently were also needed for executables. Solved problem by adding static flag to everything in fortran directories. Platforms tested: mir, eirene
Diffstat (limited to 'fortran/testpar/Makefile.am')
-rw-r--r--fortran/testpar/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/fortran/testpar/Makefile.am b/fortran/testpar/Makefile.am
index e6301d0..39aceb0 100644
--- a/fortran/testpar/Makefile.am
+++ b/fortran/testpar/Makefile.am
@@ -22,6 +22,9 @@ include $(top_srcdir)/config/commence.am
# Include files
AM_FFLAGS=-I$(top_srcdir)/fortran/src -I$(top_srcdir)/fortran/test $(F9XMODFLAG)$(top_builddir)/fortran/src
+# Fortran libraries are linked statically to solve a build problem.
+AM_LDFLAGS=-static
+
# These are our main targets
TEST_PROG_PARA=ptesthdf5_fortran
check_PROGRAMS=$(TEST_PROG_PARA)