summaryrefslogtreecommitdiffstats
path: root/fortran/testpar/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-04-25 17:43:58 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-04-25 17:43:58 (GMT)
commit1cc3666a270a15783574a2f2a7c6d9bc1209a76b (patch)
tree3eaf75101a3c2d8d76080efedede016449c700a1 /fortran/testpar/Makefile.am
parent79460590218b9944523809abf9d84688dca34a2e (diff)
downloadhdf5-1cc3666a270a15783574a2f2a7c6d9bc1209a76b.zip
hdf5-1cc3666a270a15783574a2f2a7c6d9bc1209a76b.tar.gz
hdf5-1cc3666a270a15783574a2f2a7c6d9bc1209a76b.tar.bz2
[svn-r10656] Purpose:
Output tweak Description: Test output in C++ and Fortran directories now puts "C++ API:" or "Fortran API:" in front of the name of the test being run. I had overlooked the line of code that caused this to happen. Solution: Added HDF_CXX and HDF_FORTRAN variables to C++ and Fortran Makefiles.am. Platforms tested: heping (minor change)
Diffstat (limited to 'fortran/testpar/Makefile.am')
-rw-r--r--fortran/testpar/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/fortran/testpar/Makefile.am b/fortran/testpar/Makefile.am
index 04e2ed3..ed1e4bc 100644
--- a/fortran/testpar/Makefile.am
+++ b/fortran/testpar/Makefile.am
@@ -39,6 +39,9 @@ ptesthdf5_fortran_SOURCES=thdf5.f90 ptesthdf5_fortran.f90 thyperslab_wr.f90
# The tests depend on several libraries.
LDADD=$(LIBH5FTEST) $(LIBH5TEST) $(LIBH5F) $(LIBHDF5)
+# Mark this directory as part of the Fortran API
+HDF_FORTRAN=yes
+
# Fortran module files can have different extensions and different names
# (e.g., different capitalizations) on different platforms. Write rules
# for them explicitly rather than trying to teach automake about them.