summaryrefslogtreecommitdiffstats
path: root/fortran/testpar/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-05 18:32:00 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-05 18:32:00 (GMT)
commit24f7d99d91729eef393ce56c0603d3040f65e97b (patch)
tree77a1038c243fb647f5dd8349319017949ec0bb1f /fortran/testpar/Makefile.am
parentda42955371293d17ac38ecc0854a2cff49b6f3bd (diff)
downloadhdf5-24f7d99d91729eef393ce56c0603d3040f65e97b.zip
hdf5-24f7d99d91729eef393ce56c0603d3040f65e97b.tar.gz
hdf5-24f7d99d91729eef393ce56c0603d3040f65e97b.tar.bz2
[svn-r9943] Purpose:
Bug fix Description: /fortran/testpar build breaks when making in parallel Solution: Massage depdendencies slightly to ensure that object files are built after module file. Also made sure that module file gets cleaned properly. Platforms tested: eirene
Diffstat (limited to 'fortran/testpar/Makefile.am')
-rw-r--r--fortran/testpar/Makefile.am28
1 files changed, 26 insertions, 2 deletions
diff --git a/fortran/testpar/Makefile.am b/fortran/testpar/Makefile.am
index 41414a8..ce0123a 100644
--- a/fortran/testpar/Makefile.am
+++ b/fortran/testpar/Makefile.am
@@ -36,9 +36,33 @@ ptesthdf5_fortran_SOURCES=thdf5.f90 ptesthdf5_fortran.f90 thyperslab_wr.f90
# The tests depend on several libraries.
LDADD=$(LIBH5FTEST) $(LIBH5TEST) $(LIBH5F) $(LIBHDF5)
+# Fortran module files can have different extensions and different names
+# (e.g., different capitalizations) on different platforms. Write rules
+# for them explicitly rather than trying to teach automake about them.
+# They should be installed as headers and removed during clean.
+maintainer-clean-local: clean-local
+distclean-local: clean-local
+clean-local:
+ if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
+ $(RM) *.$(F9XMODEXT); \
+ fi
+
+install-data-local:
+ if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
+ $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
+ fi
+
+uninstall-local:
+ if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
+ if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(includedir)/HDF5.$(F9XMODEXT)"; then \
+ set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
+ fi; \
+ fi; \
+ $(RM) $(bindir)/$(H5FC_NAME)
+
# Put in dependencies to the THDF5 module so that things will be built
# in the correct order.
-thyperslab_wr.lo: $(srcdir)/thyperslab_wr.f90 thdf5.lo
-ptesthdf5_fortran.lo: $(srcdir)/ptesthdf5_fortran.f90 thdf5.lo
+thyperslab_wr.o: $(srcdir)/thyperslab_wr.f90 thdf5.lo
+ptesthdf5_fortran.o: $(srcdir)/ptesthdf5_fortran.f90 thdf5.lo
include $(top_srcdir)/config/conclude.am