summaryrefslogtreecommitdiffstats
path: root/hl/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-09-16 21:49:56 (GMT)
committerGitHub <noreply@github.com>2021-09-16 21:49:56 (GMT)
commitd3b7b504d7d4933ec74ba6d4a4a7d4bbe6765b4c (patch)
tree1d5e39342996541138e31e54efde36c5700bc2fd /hl/CMakeLists.txt
parent0322d16aeaa3ddf9bc19cdee5bcc0dfb6cb46f91 (diff)
downloadhdf5-d3b7b504d7d4933ec74ba6d4a4a7d4bbe6765b4c.zip
hdf5-d3b7b504d7d4933ec74ba6d4a4a7d4bbe6765b4c.tar.gz
hdf5-d3b7b504d7d4933ec74ba6d4a4a7d4bbe6765b4c.tar.bz2
Merge HDFFV-11266 - add option to build HL tools #1018 (#1021)
Diffstat (limited to 'hl/CMakeLists.txt')
-rw-r--r--hl/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/hl/CMakeLists.txt b/hl/CMakeLists.txt
index 083c60e..5061c6c 100644
--- a/hl/CMakeLists.txt
+++ b/hl/CMakeLists.txt
@@ -7,9 +7,17 @@ project (HDF5_HL C)
add_subdirectory (src)
-#-- Build the High level Tools
+# Build HDF5 Tools
if (HDF5_BUILD_TOOLS)
- add_subdirectory (tools)
+ #-----------------------------------------------------------------------------
+ #-- Option to build the High level Tools
+ #-----------------------------------------------------------------------------
+ if (EXISTS "${HDF5_HL_SOURCE_DIR}/tools" AND IS_DIRECTORY "${HDF5_HL_SOURCE_DIR}/tools")
+ option (HDF5_BUILD_HL_TOOLS "Build HDF5 HL Tools" ON)
+ if (HDF5_BUILD_HL_TOOLS)
+ add_subdirectory (tools)
+ endif ()
+ endif ()
endif ()
#-- Add High Level Examples