summaryrefslogtreecommitdiffstats
path: root/hl/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-09-17 16:01:26 (GMT)
committerGitHub <noreply@github.com>2021-09-17 16:01:26 (GMT)
commitc9c85080e9c9ba2f98cd7bf0ca69775529e280e4 (patch)
tree8305e74cdcd23fdf57519778f03bd265a2748df5 /hl/CMakeLists.txt
parent7afad40071d918d15983c993e933e2d99f24503d (diff)
downloadhdf5-c9c85080e9c9ba2f98cd7bf0ca69775529e280e4.zip
hdf5-c9c85080e9c9ba2f98cd7bf0ca69775529e280e4.tar.gz
hdf5-c9c85080e9c9ba2f98cd7bf0ca69775529e280e4.tar.bz2
Merge HDFFV-11266 - add option to build HL tools #1018 (#1020)
Diffstat (limited to 'hl/CMakeLists.txt')
-rw-r--r--hl/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/hl/CMakeLists.txt b/hl/CMakeLists.txt
index 083c60e..5061c6c 100644
--- a/hl/CMakeLists.txt
+++ b/hl/CMakeLists.txt
@@ -7,9 +7,17 @@ project (HDF5_HL C)
add_subdirectory (src)
-#-- Build the High level Tools
+# Build HDF5 Tools
if (HDF5_BUILD_TOOLS)
- add_subdirectory (tools)
+ #-----------------------------------------------------------------------------
+ #-- Option to build the High level Tools
+ #-----------------------------------------------------------------------------
+ if (EXISTS "${HDF5_HL_SOURCE_DIR}/tools" AND IS_DIRECTORY "${HDF5_HL_SOURCE_DIR}/tools")
+ option (HDF5_BUILD_HL_TOOLS "Build HDF5 HL Tools" ON)
+ if (HDF5_BUILD_HL_TOOLS)
+ add_subdirectory (tools)
+ endif ()
+ endif ()
endif ()
#-- Add High Level Examples