summaryrefslogtreecommitdiffstats
path: root/hl/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-09-17 16:01:50 (GMT)
committerGitHub <noreply@github.com>2021-09-17 16:01:50 (GMT)
commit9e93204a23346a5b7cf5b8673cf50e6ac2497021 (patch)
treee4a289bd0235bd6fdbdb6fa4b2c932315315a84b /hl/CMakeLists.txt
parentd44f3106495830609858d424d11d85276a5237f2 (diff)
downloadhdf5-9e93204a23346a5b7cf5b8673cf50e6ac2497021.zip
hdf5-9e93204a23346a5b7cf5b8673cf50e6ac2497021.tar.gz
hdf5-9e93204a23346a5b7cf5b8673cf50e6ac2497021.tar.bz2
1.8 Merge HDFFV-11266 - add option to build HL tools #1018 (#1022)
* Merge HDFFV-11266 - add option to build HL tools #1018 * Update configure and Makefile.ins with bin/reconfigure. Co-authored-by: Larry Knox <lrknox@hdfgroup.org>
Diffstat (limited to 'hl/CMakeLists.txt')
-rw-r--r--hl/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/hl/CMakeLists.txt b/hl/CMakeLists.txt
index 083c60e..5061c6c 100644
--- a/hl/CMakeLists.txt
+++ b/hl/CMakeLists.txt
@@ -7,9 +7,17 @@ project (HDF5_HL C)
add_subdirectory (src)
-#-- Build the High level Tools
+# Build HDF5 Tools
if (HDF5_BUILD_TOOLS)
- add_subdirectory (tools)
+ #-----------------------------------------------------------------------------
+ #-- Option to build the High level Tools
+ #-----------------------------------------------------------------------------
+ if (EXISTS "${HDF5_HL_SOURCE_DIR}/tools" AND IS_DIRECTORY "${HDF5_HL_SOURCE_DIR}/tools")
+ option (HDF5_BUILD_HL_TOOLS "Build HDF5 HL Tools" ON)
+ if (HDF5_BUILD_HL_TOOLS)
+ add_subdirectory (tools)
+ endif ()
+ endif ()
endif ()
#-- Add High Level Examples