summaryrefslogtreecommitdiffstats
path: root/hl/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2021-11-23 19:15:30 (GMT)
committerGitHub <noreply@github.com>2021-11-23 19:15:30 (GMT)
commit2daa28652dc7823eac6a6fd2d7ad02d391585174 (patch)
tree0ff49369f51131e0232101faa5b9c3ae78755d0e /hl/CMakeLists.txt
parent28d0a7b1b93e3918f3c8ee361af3280a2c9ee8a4 (diff)
downloadhdf5-2daa28652dc7823eac6a6fd2d7ad02d391585174.zip
hdf5-2daa28652dc7823eac6a6fd2d7ad02d391585174.tar.gz
hdf5-2daa28652dc7823eac6a6fd2d7ad02d391585174.tar.bz2
subfiling with selection IO (#1219)
Merged branch 'selection_io' into subfiling branch.
Diffstat (limited to 'hl/CMakeLists.txt')
-rw-r--r--hl/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/hl/CMakeLists.txt b/hl/CMakeLists.txt
index 5061c6c..9391231 100644
--- a/hl/CMakeLists.txt
+++ b/hl/CMakeLists.txt
@@ -2,6 +2,14 @@ cmake_minimum_required (VERSION 3.12)
project (HDF5_HL C)
#-----------------------------------------------------------------------------
+# Option to use new-style references with dimension scale APIs
+#-----------------------------------------------------------------------------
+option (HDF5_DIMENSION_SCALES_NEW_REF "Use new-style references with dimension scale APIs" OFF)
+if (HDF5_DIMENSION_SCALES_NEW_REF)
+ set (H5_DIMENSION_SCALES_WITH_NEW_REF 1)
+endif ()
+
+#-----------------------------------------------------------------------------
# List Source files
#-----------------------------------------------------------------------------