summaryrefslogtreecommitdiffstats
path: root/hl/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-09-18 22:08:07 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-09-18 22:08:07 (GMT)
commiteff696a3b0267e89e73c08b078131b0394388449 (patch)
tree6bbc47689b9883dd83e0d550dcf9e8ba7040ce32 /hl/CMakeLists.txt
parent315ab68bd117a2c7f89b220a37adcf35b93d7c03 (diff)
downloadhdf5-eff696a3b0267e89e73c08b078131b0394388449.zip
hdf5-eff696a3b0267e89e73c08b078131b0394388449.tar.gz
hdf5-eff696a3b0267e89e73c08b078131b0394388449.tar.bz2
[svn-r22785] HDFFV-8153: Pull POSIX_C_SOURCE define out to separate variable. Use ADD_DEFINITIONS (${HDF5_EXTRA_C_FLAGS}) in non-fortran CMakeLists.txt folders
Tested: jam with intel compilers
Diffstat (limited to 'hl/CMakeLists.txt')
-rw-r--r--hl/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/hl/CMakeLists.txt b/hl/CMakeLists.txt
index d1db6ca..e66329e 100644
--- a/hl/CMakeLists.txt
+++ b/hl/CMakeLists.txt
@@ -2,6 +2,11 @@ cmake_minimum_required (VERSION 2.8.6)
PROJECT (HDF5_HL C CXX)
#-----------------------------------------------------------------------------
+# Apply Definitions to compiler in this directory and below
+#-----------------------------------------------------------------------------
+ADD_DEFINITIONS (${HDF5_EXTRA_C_FLAGS})
+
+#-----------------------------------------------------------------------------
# Shared Libs
#-----------------------------------------------------------------------------
IF (BUILD_SHARED_LIBS)