summaryrefslogtreecommitdiffstats
path: root/hl/Makefile.am
diff options
context:
space:
mode:
authorDhvanil Popat <dpopat@hdfgroup.org>2019-07-16 19:55:41 (GMT)
committerDhvanil Popat <dpopat@hdfgroup.org>2019-07-16 19:55:41 (GMT)
commit6ea31d54b80e8ceaac21a0399117aa4140b919c7 (patch)
tree0ed583989920edefdb876cd94864a52ec5573d29 /hl/Makefile.am
parent2b6e8e76ad8d0312ba9683deb9d7e28cd1748d29 (diff)
downloadhdf5-6ea31d54b80e8ceaac21a0399117aa4140b919c7.zip
hdf5-6ea31d54b80e8ceaac21a0399117aa4140b919c7.tar.gz
hdf5-6ea31d54b80e8ceaac21a0399117aa4140b919c7.tar.bz2
Added options to build tools and tests for HDF5_ 1_8
Diffstat (limited to 'hl/Makefile.am')
-rw-r--r--hl/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/hl/Makefile.am b/hl/Makefile.am
index aee1f86..0e2fd37 100644
--- a/hl/Makefile.am
+++ b/hl/Makefile.am
@@ -32,10 +32,21 @@ if BUILD_CXX_CONDITIONAL
CXX_DIR = c++
endif
+if BUILD_TESTS_CONDITIONAL
+ TEST_DIR = test
+else
+ TEST_DIR =
+endif
+if BUILD_TOOLS_CONDITIONAL
+ TOOLS_DIR = tools
+else
+ TOOLS_DIR =
+endif
+
## Don't recurse into any subdirectories if HDF5 is not configured to
## use the HL library
if BUILD_HDF5_HL_CONDITIONAL
- SUBDIRS=src test tools $(CXX_DIR) $(FORTRAN_DIR)
+ SUBDIRS=src $(TEST_DIR) $(TOOLS_DIR) $(CXX_DIR) $(FORTRAN_DIR)
endif
DIST_SUBDIRS=src test tools c++ fortran examples