summaryrefslogtreecommitdiffstats
path: root/hl/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-18 17:19:36 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-18 17:19:36 (GMT)
commit349ca8daa9a1d0f094d716ea603d7d41ac14b862 (patch)
treed5180e62e013724f1c8972c018963bfe4da74e17 /hl/Makefile.am
parentf7ee415cdb4e6000636a55ff017c516d65ed64c1 (diff)
downloadhdf5-349ca8daa9a1d0f094d716ea603d7d41ac14b862.zip
hdf5-349ca8daa9a1d0f094d716ea603d7d41ac14b862.tar.gz
hdf5-349ca8daa9a1d0f094d716ea603d7d41ac14b862.tar.bz2
[svn-r10234] Purpose:
Added Packet Table to high-level APIs Description: The Packet Table is an API that allows the user to append records ("packets") to a table, and read the back again. It supports fixed-length records with a defined datatype and variable-length records. It also supports a "current record" index to track the user's position in the table. Solution: The Packet Table code lives in hl/src, and its tests in hl/test. Some code is shared between the H5TB table and the H5PT Packet Table in the form of functions in H5HL_private.c. Some documentation exists for a previous version of the API. Updated documentation and C++ wrapper API coming soon. Platforms tested: sleipnir, eirene, copper, modi4
Diffstat (limited to 'hl/Makefile.am')
-rw-r--r--hl/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/hl/Makefile.am b/hl/Makefile.am
index f178df1..780e494 100644
--- a/hl/Makefile.am
+++ b/hl/Makefile.am
@@ -20,12 +20,10 @@ include $(top_srcdir)/config/commence.am
if BUILD_FORTRAN_CONDITIONAL
FORTRAN_DIR = fortran
endif
+##if BUILD_CXX_CONDITIONAL
+## CXX_DIR = c++
+##endif
-SUBDIRS=src test $(FORTRAN_DIR)
-
-##lib progs tests test _test:
-## @@SETX@; for d in $(SUBDIRS); do \
-## (cd $$d && $(MAKE) $@) || exit 1; \
-## done
+SUBDIRS=src test $(CXX_DIR) $(FORTRAN_DIR)
include $(top_srcdir)/config/conclude.am