summaryrefslogtreecommitdiffstats
path: root/hl/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-03-23 14:22:34 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-03-23 14:22:34 (GMT)
commit524d25498fb7e39b2ad13e674afb8a0ae3844434 (patch)
treef6330aec61ddaa49f41afdb9ddc112165064a75d /hl/Makefile.am
parent15f0a2e95c3c6ea72fe88fe8c9bc45cab7eb3212 (diff)
downloadhdf5-524d25498fb7e39b2ad13e674afb8a0ae3844434.zip
hdf5-524d25498fb7e39b2ad13e674afb8a0ae3844434.tar.gz
hdf5-524d25498fb7e39b2ad13e674afb8a0ae3844434.tar.bz2
[svn-r12143] Purpose:
Bug fix Description: make check-clean didn't clean results of example tests Solution: Fixed Makefiles so that check-clean recurses into example directories. Also a little Makefile cleanup. Platforms tested: mir, modi4, heping, copper
Diffstat (limited to 'hl/Makefile.am')
-rw-r--r--hl/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/hl/Makefile.am b/hl/Makefile.am
index 77dd458..d462a3d 100644
--- a/hl/Makefile.am
+++ b/hl/Makefile.am
@@ -44,11 +44,18 @@ DIST_SUBDIRS=src test tools c++ fortran examples
install-examples uninstall-examples:
@(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
-# Check that examples can be successfully built
-check-install:
- @$(MAKE) $(AM_MAKEFLAGS) installcheck
-
installcheck-local:
@(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+# Clean examples when check-clean is invoked
+check-clean ::
+ @$(MAKE) $(AM_MAKEFLAGS) build-$@ || exit 1;
+ @for d in X $(SUBDIRS) examples; do \
+ if test $$d != X && test $$d != .; then \
+ (set -x; cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ fi; \
+ done
+
+build-check-clean:
+
include $(top_srcdir)/config/conclude.am