summaryrefslogtreecommitdiffstats
path: root/hl/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2019-06-06 04:20:01 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2019-06-06 04:20:01 (GMT)
commit54a07f556cd2f3556f8c7946fe7905bc658a11aa (patch)
tree2563b439aa79df337a7d4b4ec884be0d535ee1b8 /hl/Makefile.am
parent4af633d1c480deb7d27c1da7ee2c512a2500e543 (diff)
downloadhdf5-54a07f556cd2f3556f8c7946fe7905bc658a11aa.zip
hdf5-54a07f556cd2f3556f8c7946fe7905bc658a11aa.tar.gz
hdf5-54a07f556cd2f3556f8c7946fe7905bc658a11aa.tar.bz2
Add options to enable or disable building tools and tests. The default
is enabled for each.
Diffstat (limited to 'hl/Makefile.am')
-rw-r--r--hl/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/hl/Makefile.am b/hl/Makefile.am
index 172d0e8..ded7aa0 100644
--- a/hl/Makefile.am
+++ b/hl/Makefile.am
@@ -31,11 +31,21 @@ endif
if BUILD_CXX_CONDITIONAL
CXX_DIR = c++
endif
+if BUILD_TESTS_CONDITIONAL
+ TEST_DIR = test
+else
+ TEST_DIR =
+endif
+if BUILD_TOOLS_CONDITIONAL
+ TOOLS_DIR = tools
+else
+ TOOLS_DIR =
+endif
## Don't recurse into any subdirectories if HDF5 is not configured to
## use the HL library
if BUILD_HDF5_HL_CONDITIONAL
- SUBDIRS=src test tools $(CXX_DIR) $(FORTRAN_DIR)
+ SUBDIRS=src $(TEST_DIR) $(TOOLS_DIR) $(CXX_DIR) $(FORTRAN_DIR)
# Test with just the native connector, with a single pass-through connector
# and with a doubly-stacked pass-through.