summaryrefslogtreecommitdiffstats
path: root/hl/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-12-09 20:59:11 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-12-09 20:59:11 (GMT)
commitb1fd3f565750a18246239cdac50e433d6d668524 (patch)
treef09179e1fb2a04e01983c85f9a3873c159fefda7 /hl/Makefile.am
parent9124030f911f002bd49ec8bccd4c051df410cc72 (diff)
downloadhdf5-b1fd3f565750a18246239cdac50e433d6d668524.zip
hdf5-b1fd3f565750a18246239cdac50e433d6d668524.tar.gz
hdf5-b1fd3f565750a18246239cdac50e433d6d668524.tar.bz2
[svn-r11780] Purpose:
Added high-level example directories Description: Refactored common code out of examples Makefiles.am, added high-level example directories, added packet table examples. Solution: Examples now draw from a common config/examples.am file, which contains rules for installing, uninstalling, and cleaning examples. High-level example directories are mostly empty, except for the C and C++ packet table tests. Platforms tested: mir, sleipnir, copper, shanti
Diffstat (limited to 'hl/Makefile.am')
-rw-r--r--hl/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/hl/Makefile.am b/hl/Makefile.am
index 8064ba1..c4b6787 100644
--- a/hl/Makefile.am
+++ b/hl/Makefile.am
@@ -38,5 +38,17 @@ endif
if BUILD_HDF5_HL_CONDITIONAL
SUBDIRS=src test $(CXX_DIR) $(FORTRAN_DIR)
endif
+DIST_SUBDIRS=src test c++ fortran examples
+
+# Install examples
+install-examples uninstall-examples:
+ @(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+
+# Check that examples can be successfully built
+check-install:
+ @$(MAKE) $(AM_MAKEFLAGS) installcheck
+
+installcheck-local:
+ @(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
include $(top_srcdir)/config/conclude.am