summaryrefslogtreecommitdiffstats
path: root/hl/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-09-16 17:15:25 (GMT)
committerGitHub <noreply@github.com>2021-09-16 17:15:25 (GMT)
commitc0f2bc87aca0ddfed4bbf1a75dda5ea71b6617eb (patch)
tree9db02def5d5567804d3c8f8bf615ed07f3b6d3ba /hl/Makefile.am
parentdaeb4454f6d8b72d5fab6a78546859b2182bd248 (diff)
downloadhdf5-c0f2bc87aca0ddfed4bbf1a75dda5ea71b6617eb.zip
hdf5-c0f2bc87aca0ddfed4bbf1a75dda5ea71b6617eb.tar.gz
hdf5-c0f2bc87aca0ddfed4bbf1a75dda5ea71b6617eb.tar.bz2
HDFFV-11266 - add option to build HL tools (#1018)
* HDFFV-11266 - add option to build HL tools * Correct if syntax * Correct name of conditional
Diffstat (limited to 'hl/Makefile.am')
-rw-r--r--hl/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/hl/Makefile.am b/hl/Makefile.am
index 9bf209e..8c427d3 100644
--- a/hl/Makefile.am
+++ b/hl/Makefile.am
@@ -37,16 +37,19 @@ else
TEST_DIR =
endif
if BUILD_TOOLS_CONDITIONAL
+if BUILD_TOOLS_HL_CONDITIONAL
TOOLS_DIR = tools
else
TOOLS_DIR =
endif
+else
+ TOOLS_DIR =
+endif
## Don't recurse into any subdirectories if HDF5 is not configured to
## use the HL library
if BUILD_HDF5_HL_CONDITIONAL
SUBDIRS=src $(TEST_DIR) $(TOOLS_DIR) $(CXX_DIR) $(FORTRAN_DIR)
-
endif
DIST_SUBDIRS=src test tools c++ fortran examples