summaryrefslogtreecommitdiffstats
path: root/hl/c++/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-28 16:32:20 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-28 16:32:20 (GMT)
commit9452992c091df0bc7451a8d3ee0eea771cf5b97b (patch)
treeb07dec93daa39a432f47cb0b35a59e939adbff06 /hl/c++/Makefile.am
parentaf6d77bfc4effe7e206745d2ef8da06fd0a7e58a (diff)
downloadhdf5-9452992c091df0bc7451a8d3ee0eea771cf5b97b.zip
hdf5-9452992c091df0bc7451a8d3ee0eea771cf5b97b.tar.gz
hdf5-9452992c091df0bc7451a8d3ee0eea771cf5b97b.tar.bz2
[svn-r10459]
Purpose: Added C++ wrapper for Packet Table API. Description: Added macro for high-level C++ library (LIBH5CPP_HL), which changes every Makefile.in. Added directories for high-level C++ library (though currently only Packet Table API is supported). Added both C++ source and tests. Platforms tested: sleipnir, mir, modi4 Misc. update:
Diffstat (limited to 'hl/c++/Makefile.am')
-rw-r--r--hl/c++/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/hl/c++/Makefile.am b/hl/c++/Makefile.am
new file mode 100644
index 0000000..a2d4315
--- /dev/null
+++ b/hl/c++/Makefile.am
@@ -0,0 +1,24 @@
+#
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdf.ncsa.uiuc.edu/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from hdfhelp@ncsa.uiuc.edu.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# High-Level API C++ Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+SUBDIRS=src test
+
+include $(top_srcdir)/config/conclude.am