summaryrefslogtreecommitdiffstats
path: root/hl/c++/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-05-09 19:29:44 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-05-09 19:29:44 (GMT)
commit37c27afde06c02416b6cc8bf518fea534aef0af6 (patch)
tree043fe9bcc9a2522bfe5ccabbaf1e67570611effe /hl/c++/examples/CMakeLists.txt
parentdcc66a4f157ace0858b788228550f3e104df3242 (diff)
downloadhdf5-37c27afde06c02416b6cc8bf518fea534aef0af6.zip
hdf5-37c27afde06c02416b6cc8bf518fea534aef0af6.tar.gz
hdf5-37c27afde06c02416b6cc8bf518fea534aef0af6.tar.bz2
Fix MPI on Windows by adding MPI include folder
Diffstat (limited to 'hl/c++/examples/CMakeLists.txt')
-rw-r--r--hl/c++/examples/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/hl/c++/examples/CMakeLists.txt b/hl/c++/examples/CMakeLists.txt
index e66aa81..8e64239 100644
--- a/hl/c++/examples/CMakeLists.txt
+++ b/hl/c++/examples/CMakeLists.txt
@@ -5,7 +5,7 @@ project (HDF5_HL_CPP_EXAMPLES CXX)
# Add in the examples for the Packet Table codes
# --------------------------------------------------------------------
add_executable (ptExampleFL ${HDF5_HL_CPP_EXAMPLES_SOURCE_DIR}/ptExampleFL.cpp)
-target_include_directories(ptExampleFL PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR}")
+target_include_directories(ptExampleFL PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
TARGET_C_PROPERTIES (ptExampleFL STATIC)
target_link_libraries (ptExampleFL PRIVATE
${HDF5_HL_CPP_LIB_TARGET}