summaryrefslogtreecommitdiffstats
path: root/hl/c++/src/Makefile.am
diff options
context:
space:
mode:
authorVailin Choi <vchoi@hdfgroup.org>2013-10-24 21:42:38 (GMT)
committerVailin Choi <vchoi@hdfgroup.org>2013-10-24 21:42:38 (GMT)
commit07a49f439fc44ddec27fd6a25ee0fd52de87ec3c (patch)
tree09a088c34a092f42fdb4502d3ea25a6f16cc892b /hl/c++/src/Makefile.am
parentbfd1c84d5cdc403c1414395cd49197cd4fc74108 (diff)
downloadhdf5-07a49f439fc44ddec27fd6a25ee0fd52de87ec3c.zip
hdf5-07a49f439fc44ddec27fd6a25ee0fd52de87ec3c.tar.gz
hdf5-07a49f439fc44ddec27fd6a25ee0fd52de87ec3c.tar.bz2
[svn-r24354] Bring revision #24336 from revise_chunks.
h5committested.
Diffstat (limited to 'hl/c++/src/Makefile.am')
-rw-r--r--hl/c++/src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/hl/c++/src/Makefile.am b/hl/c++/src/Makefile.am
index d2794c9..7961747 100644
--- a/hl/c++/src/Makefile.am
+++ b/hl/c++/src/Makefile.am
@@ -40,8 +40,11 @@ endif
# At the moment, only the H5PT Packet Table has a C++ API.
libhdf5_hl_cpp_la_SOURCES=H5PacketTable.cpp
-# HDF5 HL C++ library depends on HDF5 HL Library and HDF5 C++ Library.
+# HDF5 HL C++ library depends on HDF5 Library. However, only add the dependency
+# if --enable-sharedlib-rpath is yes.
+if LT_ADD_LIBHDF5_DEPENDENCY
libhdf5_hl_cpp_la_LIBADD=$(LIBH5_HL) $(LIBH5CPP)
+endif
# Public headers
include_HEADERS=H5PacketTable.h