summaryrefslogtreecommitdiffstats
path: root/hl/c++/src/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-04-20 06:03:29 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-04-20 06:03:29 (GMT)
commit833921737479e9b33b8397a766fe9e5b20936e3b (patch)
treed24eb7c81f87f9404c1c19adb5006d6119b35119 /hl/c++/src/Makefile.am
parentd380fe5398b60894a81c73b4ef9ccc5fcadafbc2 (diff)
downloadhdf5-833921737479e9b33b8397a766fe9e5b20936e3b.zip
hdf5-833921737479e9b33b8397a766fe9e5b20936e3b.tar.gz
hdf5-833921737479e9b33b8397a766fe9e5b20936e3b.tar.bz2
[svn-r16793] Description:
- Updated bin/reconfigure to use latest version of automake (1.10.2). Regenerated Makefile.in's by running bin/reconfigure. - Added libtool version numbers to c++, fortran, hl, hl c++, and hl fortran libraries. Tested: jam, liberty, smirom
Diffstat (limited to 'hl/c++/src/Makefile.am')
-rw-r--r--hl/c++/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hl/c++/src/Makefile.am b/hl/c++/src/Makefile.am
index 8d2e869..1ff24be 100644
--- a/hl/c++/src/Makefile.am
+++ b/hl/c++/src/Makefile.am
@@ -19,6 +19,7 @@
#
include $(top_srcdir)/config/commence.am
+include $(top_srcdir)/config/lt_vers.am
# Include src directory
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/hl/src
@@ -26,6 +27,9 @@ INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/hl/src
# This is our main target
lib_LTLIBRARIES=libhdf5_hl_cpp.la
+# Add libtool numbers to the HDF5 HL C++ library (from config/lt_vers.am)
+libhdf5_hl_cpp_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE)
+
# Shared C++ libraries aren't universally supported.
if CXX_SHARED_CONDITIONAL
else