summaryrefslogtreecommitdiffstats
path: root/hl/c++/src/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2014-04-25 21:59:53 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2014-04-25 21:59:53 (GMT)
commitc6e3e682973aa793844e39376cb7ada93ce505ba (patch)
tree190929e40042c15843c28d591a1c0e336c743dc4 /hl/c++/src/Makefile.am
parent7309bb5ab8810a701d5aa98c8068b98792585d9a (diff)
downloadhdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.zip
hdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.tar.gz
hdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.tar.bz2
[svn-r25117] Removed LT_ADD_LIBHDF5_DEPENDENCY configure conditional to roll back fix for removing rpaths from l
ib files. The fix also removed dependencies on libhdf5, etc. when the --disable-sharedlib-rpath co nfigure option was invoked. Added instead configure variable hardcode_into_lib=no. This removes rpath from lib files on Linux and solaris machines. Tested with h5committest on jam, koala, ostrich and platypus (cmake), and with configure option --disable-sharedlib-rpath on emu, platypus and quail.
Diffstat (limited to 'hl/c++/src/Makefile.am')
-rw-r--r--hl/c++/src/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/hl/c++/src/Makefile.am b/hl/c++/src/Makefile.am
index 03289c0..9751e94 100644
--- a/hl/c++/src/Makefile.am
+++ b/hl/c++/src/Makefile.am
@@ -40,11 +40,8 @@ endif
# At the moment, only the H5PT Packet Table has a C++ API.
libhdf5_hl_cpp_la_SOURCES=H5PacketTable.cpp
-# HDF5 HL C++ library depends on HDF5 Library. However, only add the dependency
-# if --enable-sharedlib-rpath is yes.
-if LT_ADD_LIBHDF5_DEPENDENCY
+# HDF5 HL C++ library depends on HDF5 Library.
libhdf5_hl_cpp_la_LIBADD=$(LIBH5_HL) $(LIBH5CPP)
-endif
# Public headers
include_HEADERS=H5PacketTable.h