summaryrefslogtreecommitdiffstats
path: root/hl/c++/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2020-09-27 20:03:44 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-09-27 20:03:44 (GMT)
commit08034972bc4818e8550445aa7f4fd0b315800190 (patch)
tree14ab13613f3c411d0b3248455244f29418ef887b /hl/c++/test/CMakeLists.txt
parentd20e1274a7bbf8ab1f87f3ebd61cea82ac8caf53 (diff)
parentaa08db839e6aea89487be985704d57a0e424b21b (diff)
downloadhdf5-08034972bc4818e8550445aa7f4fd0b315800190.zip
hdf5-08034972bc4818e8550445aa7f4fd0b315800190.tar.gz
hdf5-08034972bc4818e8550445aa7f4fd0b315800190.tar.bz2
Merge remote-tracking branch 'hdffv/develop' into rebased-fprintf-experiment
Diffstat (limited to 'hl/c++/test/CMakeLists.txt')
-rw-r--r--hl/c++/test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/hl/c++/test/CMakeLists.txt b/hl/c++/test/CMakeLists.txt
index 5c224a8..246a670 100644
--- a/hl/c++/test/CMakeLists.txt
+++ b/hl/c++/test/CMakeLists.txt
@@ -25,6 +25,13 @@ else ()
endif ()
set_target_properties (hl_ptableTest PROPERTIES FOLDER test/hl/cpp)
+#-----------------------------------------------------------------------------
+# Add Target to clang-format
+#-----------------------------------------------------------------------------
+if (HDF5_ENABLE_FORMATTERS)
+ clang_format (HDF5_HL_CPP_TEST_FORMAT hl_ptableTest)
+endif ()
+
if (HDF5_TEST_CPP AND HDF5_TEST_SERIAL)
include (CMakeTests.cmake)
endif ()